File upload is very slow
Incident Report for hackajob
Resolved
This incident has been resolved.
Posted Jan 31, 2023 - 13:28 UTC
Investigating
File upload is very slow. We identified the root cause and the dev team is working on making a fix.
Posted Jan 31, 2023 - 11:56 UTC
This incident affected: Talent Application and Talent Assessment Application.